Erste Beta von ClassicPress veröffentlicht

Nach einem Monat Arbeit wurde die Tage die erste Beta des WordPress Forks ClassicPress veröffentlicht. ClassicPress basiert auf der letzten Gutenberg freien WordPress Version. Das ist die jetzt aktuelle Version 4.9.8.

Ich habe diese Beta einige Tage getestet. ClassicPress ist zurzeit nur an dem geänderten Namen, den man überall antrifft, zu erkennen. Ansonsten fühlt sich dieses CMS noch immer wie WordPress an. Ich selbst bin noch immer etwas unschlüssig. Mit Gutenberg komme ich gut zurecht, liebe aber noch immer den guten, alten TinyMCE

Änderungen der ersten Beta

  • Die automatischen Updates von ClassicPress sind jetzt implementierte GPG signierte Releases.
  • Die Arbeit an der Bereitstellung von Übersetzungen aus der ClassicPress-Infrastruktur wurde abgeschlossen.
  • Alter Code zur Kompatibilität für PHP 5.5 und niedriger wurde entfernt.
  • Es wurden weitere WordPress-spezifische Formulierungen und Admin-Dashboard-Inhalte entfernt / geändert.
  • Alle Build-Abhängigkeiten sind jetzt auf dem neuesten Stand gehalten.
  • Verschiedene andere Korrekturen und Verbesserungen im Entwicklungsprozess.
  • Das neue ClassicPress-Logo und das Markenzeichen „Business-based CMS“ wurden hinzugefügt.

PS: einen guten Artikel zu den Hintergründen von ClassicPress findet ihr hier.

4 Antworten auf “Erste Beta von ClassicPress veröffentlicht”

  1. Hallo!
    Ich interessiere mich auch für ClassicPress, weil Gutenberg kommt mir nicht ins Haus.
    Leider ist mein Englisch zu schlecht, um bei classicpress.net mitzureden, Erfahrungen, Fehler usw, dort zu deponieren oder Hilfe zu finden.

    Daher danke für diese (einzige?) dt. Praxis-Info, Erfahrungsberichte zu dem Projekt! Und daher nerve ich auch Dich mit meinen Eindrücken vom ersten CP Versuch.

    Ich habe eine kleine, auf WP 498 basierte Website zu CP migriert. Das ging auch nach mehrmaligen Anstoßen des Upgrades (am blauen Button (s. https://i.imgur.com/emPUR9j.jpg))
    Da kam immer: „Eine andere Aktualisierung wird durchgeführt“ (s. https://i.imgur.com/TQxGgUm.jpg) KA, warum? Irgendwann klappte es aber, „Welcome to ClassicPress“ erschien.

    So, die Site hatte nun über 500 geänderte und 3 neue Dateien (s. https://i.imgur.com/0N58bDZ.jpg) und sie funzte!

    ABER: Ich konnte keine Kategorie uo. Beiträge aufrufen!
    Erst als ich die Permalink-Struktur von „Beitragsname“ zu „Einfach“ (also mit …/?p=1) ging es.
    Ist das bei dir auch so?

    Evtl. können wir uns über das Projekt austauschen?

    mfg. tinyfan

    Antworten

    1. Hab schon WordPress nach ClassicPress via Plugin umgestellt und auch neu installiert. In beiden Fällen hatte ich keine Fehler. Auch die Permalink-Struktur wurde übernommen. Das ClassicPress Plugin hat dich auf geänderte Core-Dateien hingewiesen. Hattest du an den WordPress Dateien etwas geändert?

      Antworten

      1. Hallo!

        Nein, an den Core-Dateien mach ich nie was, und viele Plugins hat diese Testseite auch nicht. Ja, wie immer mach ich ein Child-Theme. Nur es funzt auch mit den Original-Themes nichts.
        Wobei der Fehler mit Plugins uo. Themes wahrscheinlich nichts zu tun hat.

        Aber die Migration hat genau 523 Dateien geändert (evtl. auch nur erneuert?) u. 3 neue hinzu (2 davon Grafiken)
        Der Quellcode-Vergleich ergab zu 99% nur Text-Änderungen wie eben „WordPress“ zu „ClassicPress“ geändert.

        Fehlermeldungen sind immer hilfreich, doch idF. ist bloß: „Objekt nicht gefunden! Der angeforderte URL konnte auf …“ 404 also.

        Antworten

        1. Berichtigung zur meiner vorigen AW:
          – es wurden 529 (nicht 523) Dateien verändert (beim Upgrade via Plugin)
          – Nicht das Plugin hat mich darauf aufmerksam gemacht, sondern der Screenshot ist von einem Vergleichstool.
          ———————————————

          NEWS:
          Alles hat geklappt!
          Habe das ganze rückgängig gemacht, die WP Version wieder hergestellt. Passt.

          Dann alles nochmal migrieren, nun OHNE Plugin (https://docs.classicpress.net/installing-classicpress/#migrating-to-classicpress-without-using-the-plugin)
          Passt!
          Alles funzt, egal welche Permalink-Struktur man einstellt, alles perfekt.

          Anm.: Es wurden vom Vergleichstool nun 528 Dateien als verändert angezeigt. Eine weniger als mit dem Plugin – nur welche? Weiß nicht. Egal, Hauptsache es funzt nun.

          Anm.2: Habe mir das Plugin ein bissl angeschaut, (als ob ich mich da auskennen würde 😉 ) und mir fiel nur eines auf: Eine der aufgerufenen Funktionen, die irgendwas mit „links“ zu tun hat, gibt es gar nicht …

          Antworten

Schreibe einen Kommentar

Diese Kommentarfunktion sammelt die Daten die im Kommentar-Formular angezeigt werden. Außerdem werden Datum und Uhrzeit des Kommentars gespeichert.

Ich bin mit der Speicherung und Verarbeitung meiner Daten durch diese Seite einverstanden